Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2016-06-16 17:29:22

Sergey Hartmann
Contributor
Registered: 2016-06-16
Posts: 6

[solved]Updating bootrom problems

Hi!

Computer not sees my proxmark3 after update bootrom. Now when I connect to the computer all the time burning red and yellow LEDs. If enter a command ls /dev/cu* in a terminal (macOS), then lists proxmark3 will not...

That's what I did when updating:
1) I detected installed bootrom in the Proxmark3 (CDC).
2) While holding the button, I connected to the computer proxmark3 (burning red and yellow LEDs).
3) Flash Bootrom ./client/flasher /dev/cu.usbmodem#### -b bootrom/obj/bootrom.elf. An error message was not. Terminal log I did not keep unfortunately (I know I'm stupid).


After step 3 computer does not see proxmark3. I tried to disconnect the Proxy Mark 3 and reconnect it - did not help...

What could be the problem? And is it possible to somehow resurrect my pm? sad sad sad

Last edited by Sergey Hartmann (2016-06-18 15:11:18)

Offline

#2 2016-06-16 17:43:27

iceman
Administrator
Registered: 2013-04-25
Posts: 6,175
Website

Re: [solved]Updating bootrom problems

try connecting it while pressing the button,   and keep it pressed,  and flash fullimage.elf..   its a one-hand-operation


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2016-06-16 17:58:19

Sergey Hartmann
Contributor
Registered: 2016-06-16
Posts: 6

Re: [solved]Updating bootrom problems

iceman, thx for answering. I'll try to come home like and just tell you about the result.

Offline

#4 2016-06-16 20:24:59

Sergey Hartmann
Contributor
Registered: 2016-06-16
Posts: 6

Re: [solved]Updating bootrom problems

iceman, it worked. Thank you so much!
Topic can be closed.

Offline

#5 2016-06-16 20:42:45

iceman
Administrator
Registered: 2013-04-25
Posts: 6,175
Website

Re: [solved]Updating bootrom problems

you are welcome.  You can edit your first post and add "[solved]" to the subject.

Enjoy yr updated pm3!


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#6 2019-05-17 07:47:08

theguy
Contributor
Registered: 2017-08-08
Posts: 49

Re: [solved]Updating bootrom problems

Same problem, holding the button when connecting the cable makes it either get to

Waiting for Proxmark to appear on /dev/ttyACM0......... Found.

Flashing...
Writing segments for file: armsrc/obj/fullimage.elf
 0x00102000..0x00139f2f [0x37f30 / 448 blocks]..................................................................................

or

Waiting for Proxmark to appear on /dev/ttyACM0 .........
 Found.
Waiting for a response from the proxmark...          
You can cancel this operation by pressing the pm3 button

SOLVED.

The key was

sudo apt purge modemmanager

Now I can run the image no problem!

Last edited by theguy (2019-05-17 07:52:29)

Offline

Board footer

Powered by FluxBB