Proxmark developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2018-04-23 21:36:29

osbock
Contributor
Registered: 2018-04-23
Posts: 9

[solved, kindof]What am I doing wrong (script execution fails)

Hi all,
I built from source after some permissions problems with the brew install on MacOS. I successfully updated the firmware, and have been happily exploring the various commands.

However, when I try to execute a script I get:proxmark3> script run ndef_dump
--- Executing: ndef_dump.lua, args ''
<...>proxmark3/client/lualibs/commands.lua:8: bad argument #1 to 'pairs' (table expected, got boolean)

I can do a script list, etc. So I don't think it's a path problem

Last edited by osbock (2018-04-24 17:00:39)

Offline

#2 2018-04-24 17:02:06

osbock
Contributor
Registered: 2018-04-23
Posts: 9

Re: [solved, kindof]What am I doing wrong (script execution fails)

I still don't know what's wrong with my built version (git clone....) but I tried the brew install again.
It failed with the error below. I tried using --HEAD as mentioned in the instructions, and Success! scripts work for me.
brew install proxmark3
==> Installing proxmark3 from proxmark/proxmark3
==> Downloading https://github.com/proxmark/proxmark3/archive/v3.0.1.tar.gz
Already downloaded: /Users/zua691/Library/Caches/Homebrew/proxmark3-3.0.1.tar.gz
==> make clean
==> make all
Error: No such file or directory - client/emv/capk.txt

Offline

#3 2018-04-24 19:25:37

iceman
Administrator
Registered: 2013-04-25
Posts: 4,935
Website

Re: [solved, kindof]What am I doing wrong (script execution fails)

the issue with homebrew is that the normal installation downloads the latest release zip (v3.0.1) from july 2017,   and since then there has been alot of fixes and changes. 
--HEAD is downloading / installing the latest source from Github where you get all the fixes/additions.

Until we make a new release,  the homebrew will have this issue.


&#20912;&#20154;

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#4 2018-04-25 00:48:52

osbock
Contributor
Registered: 2018-04-23
Posts: 9

Re: [solved, kindof]What am I doing wrong (script execution fails)

It's better than a lot of homebrew taps, maintained by someone not involved with whatever project is supported. Thanks for taking care of it all!

Offline

#5 2018-04-25 08:09:01

piwi
Moderator
Registered: 2013-06-04
Posts: 539

Re: [solved, kindof]What am I doing wrong (script execution fails)

You are reporting two different issues.

Error: No such file or directory - client/emv/capk.txt

I have tried to fix that one. I don't have access to MacOS, therefore it is an educated guess. Please give it a try (both with and without --HEAD) and report back.

proxmark3> script run ndef_dump
--- Executing: ndef_dump.lua, args ''
<...>proxmark3/client/lualibs/commands.lua:8: bad argument #1 to 'pairs' (table expected, got boolean)

Can you please check if you get some errors or warnings during brew install (probably mentioning "usb_cmd")

Offline

#6 2018-04-25 11:03:23

osbock
Contributor
Registered: 2018-04-23
Posts: 9

Re: [solved, kindof]What am I doing wrong (script execution fails)

Yes, I know I was reporting two different issues.
1. Looks like you fixed it!
2. I ran both release and --HEAD, and no errors.
Thanks! (and I closed the github issue with comment verifying fix)

Offline

#7 2018-04-25 11:47:54

piwi
Moderator
Registered: 2013-06-04
Posts: 539

Re: [solved, kindof]What am I doing wrong (script execution fails)

osbock wrote:

2. I ran both release and --HEAD, and no errors.

Meaning that the issue with ndef_dump is gone or that you cannot find any error or warning during brew install?

Offline

#8 2018-04-25 13:03:38

osbock
Contributor
Registered: 2018-04-23
Posts: 9

Re: [solved, kindof]What am I doing wrong (script execution fails)

Apologies.
1. The brew install issue is fixed.
2. The brew install version doesn't have the script running problem (it was all scripts, not just ndef_dump) My github clone does exhibit this problem.

For now, I'm happy (and really digging proxmark3!) and I'll poke around on my own to see if I can figure out the github build problem so you can stand down smile

(And thanks for the quick and helpful response!)

Last edited by osbock (2018-04-25 13:04:36)

Offline

Board footer

Powered by FluxBB