Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-12-10 23:39:29

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

RRG/Iceman repo

I'm obviously a complete noob, but I'm trying to get the RRG/Iceman repo running.

I'm programming trough Windows, so I followed this walktrough first (https://github.com/RfidResearchGroup/pr … uctions.md)

After that I followed the compilation instructions (https://github.com/RfidResearchGroup/pr … uctions.md)

No matter what I try, I keep getting the communication error below..


pm3 ~/proxmark3$ client/proxmark3.exe com5


  ██████╗ ███╗   ███╗ ████╗     ...iceman repo
  ██╔══██╗████╗ ████║   ══█║
  ██████╔╝██╔████╔██║ ████╔╝
  ██╔═══╝ ██║╚██╔╝██║   ══█║     iceman@icesql.net
  ██║     ██║ ╚═╝ ██║ ████╔╝    https://github.com/rfidresearchgroup/proxmark3/
  ╚═╝     ╚═╝     ╚═╝ ╚═══╝  pre-release v4.0

[=] Session log C:\Users\IWNL\Downloads\ProxSpace-64\pm3/.proxmark3/log_20191210.txt
[=] Using UART port com5
unknown command:: 0x61334d50[!!] ERROR: cannot communicate with the Proxmark


I found some interesting posts about the same ERROR code, but these solutions didn't seem to work for me. Or it's just me not understanding.

Please help a noob out smile

Offline

#2 2019-12-11 09:52:32

iceman
Administrator
Registered: 2013-04-25
Posts: 6,695
Website

Re: RRG/Iceman repo

You are trying to run the client...
now did you flash the firmware first?

since your error message indicates a non updated firmware running on your device

unknown command:: 0x61334d50[!!] 

If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2019-12-11 10:21:07

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

Re: RRG/Iceman repo

My bad, I'm trying to run the client indeed.

I feel like I didn't flash the firmware indeed; if it's not in the tutorials above I didn't do it. The tutorial learned how to flash the bootloader, but this is something else right?

I'm eager to learn. Can you tell me how to, or maybe refer me to a another tutorial.

Offline

#4 2019-12-11 11:23:03

iceman
Administrator
Registered: 2013-04-25
Posts: 6,695
Website

Re: RRG/Iceman repo

its pretty well documented on the Github repo.  Just take your time read it...


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#5 2019-12-26 11:57:16

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

Re: RRG/Iceman repo

I'm sorry; I read multiple articles but I obviously don't know what I'm doing wrong.

In the "compilation instructions" they speak about "Flash the BOOTROM & FULLIMAGE". I did this allready, so apparantly I need to do something different (firmware flashing and bootrom/fullimage flashing aren't obviously the same?). Furthermore can't I find a how to about flashing the firmware..

Could you or anyone direct me to the exact information I need since I apparantly don't know what to- and how to search for(?). The search function hasn't helped out yet any much either when I try to search for "firmware flashing" or terms like that.

Offline

#6 2019-12-26 13:19:45

iceman
Administrator
Registered: 2013-04-25
Posts: 6,695
Website

Re: RRG/Iceman repo

Pure guessing since you don't provide no information at all of what you actually done and what you didn't do.
The guides in your first post does a pretty good job in explaining what to do,  RTFM


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#7 2019-12-26 13:39:16

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

Re: RRG/Iceman repo

I did thoroughly RTFM.. I'll do every step again and make a screendump; hopefully u can tell me what's wrong then.

Offline

#8 2019-12-29 19:04:48

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

Re: RRG/Iceman repo

I might have found it, but still don't know how to fix this. When I try to "Flash the BOOTROM & FULLIMAGE", I get the following notification:

pm3 ~/proxmark3$ ./pm3-flash-all
[=] Waiting for Proxmark3 to appear...
[=] Session log C:\Users\IWNL\Downloads\ProxSpace-64\pm3/.proxmark3/log_20191229.txt
[+] About to use the following files:
[+]     C:\Users\IWNL\Downloads\ProxSpace-64\pm3\proxmark3\client\../bootrom/obj/bootrom.elf
[+]     C:\Users\IWNL\Downloads\ProxSpace-64\pm3\proxmark3\client\../armsrc/obj/fullimage.elf
[+] Waiting for Proxmark3 to appear on COM4
.Found
[+] Entering bootloader...
[+] (Press and release the button only to abort )
[+] Waiting for Proxmark3 to appear on COM4
............ Found
[!!] ====================== OBS ! ===========================================
[!!] Note: Your bootloader does not understand the new CMD_BL_VERSION command
[!!] It is recommended that you first update your bootloader alone,
[!!] reboot the Proxmark3 then only update the main firmware

[=] Available memory on this board: UNKNOWN

[!!] ====================== OBS ! ======================================
[!!] Note: Your bootloader does not understand the new CHIP_INFO command
[!!] It is recommended that you first update your bootloader alone,
[!!] reboot the Proxmark3 then only update the main firmware

[=] Permitted flash range: 0x00100000-0x00140000
[+] Loading ELF file C:\Users\IWNL\Downloads\ProxSpace-64\pm3\proxmark3\client\../bootrom/obj/bootrom.elf
[+] Loading usable ELF segments:
[+]    0 : V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
[+]    1 : V 0x00200000 P 0x00100200 (0x00000de0->0x00000de0) [R X] @0x298

[+] Loading ELF file C:\Users\IWNL\Downloads\ProxSpace-64\pm3\proxmark3\client\../armsrc/obj/fullimage.elf
[+] Loading usable ELF segments:
[+]    0 : V 0x00102000 P 0x00102000 (0x0003fc80->0x0003fc80) [R X] @0x94
[!!] Error: PHDR is not contained in Flash
[+] All done.

Have a nice day!
pm3 ~/proxmark3$ ./pm3-flash -b /tmp/my-bootrom.elf /tmp/my-fullimage.elf
[=] Waiting for Proxmark3 to appear...
[=] Session log C:\Users\IWNL\Downloads\ProxSpace-64\pm3/.proxmark3/log_20191229.txt
[-] Error - can't find C:/Users/IWNL/Downloads/ProxSpace-64/msys2/tmp/my-bootrom.elf
[!!] Aborted on error.

Have a nice day!
pm3 ~/proxmark3$ ./proxmark3 /dev/ttyACM0 --flash --unlock-bootloader --image /tmp/my-bootrom.elf --image /tmp/my-fulli
mage.elf
bash: ./proxmark3: No such file or directory
pm3 ~/proxmark3$ ./pm3-flash -b /tmp/my-bootrom.elf /tmp/my-fullimage.elf
[=] Waiting for Proxmark3 to appear...
[=] Session log C:\Users\IWNL\Downloads\ProxSpace-64\pm3/.proxmark3/log_20191229.txt
[-] Error - can't find C:/Users/IWNL/Downloads/ProxSpace-64/msys2/tmp/my-bootrom.elf
[!!] Aborted on error.

Have a nice day!



So as far as I can understand the "pm3-flash-all" command isn't executed correctly, and that's why the command below that command isn't working.


So my next question is thereafter; how do I "reboot the Proxmark3 then only update the main firmware"?

Offline

#9 2019-12-29 19:49:14

iceman
Administrator
Registered: 2013-04-25
Posts: 6,695
Website

Re: RRG/Iceman repo

Your flashing fails. 

[-] Error - can't find C:/Users/IWNL/Downloads/ProxSpace-64/msys2/tmp/my-bootrom.elf
[!!] Aborted on error.

If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#10 2019-12-29 19:58:39

XT4T1C
Contributor
Registered: 2019-10-12
Posts: 19

Re: RRG/Iceman repo

Thank you, I figured so..

I'm trying to get to know why it fails so I can fix it. Am I right that the "pm3-flash-all" command isn't working correctly either?

The error message you reply to indicates that a file is missing; isn't there a possibilty to drag and drop this file to the indicated directory or it this a completely stupid idea of mine?

Last edited by XT4T1C (2019-12-29 19:59:20)

Offline

#11 2020-03-15 21:18:37

fluxxion
Contributor
Registered: 2020-03-06
Posts: 10

Re: RRG/Iceman repo

This post seems a little old so not sure if you're still having issues, but I had some weird issues with using the pm3-flash-all command as well. I think I was getting basically the same output as you, XT4T1C, and in the output it says "It is recommended that you first update your bootloader alone", so that's what I did and that worked. After updating the bootrom, then I updated the full image. I think one time it was having trouble finding the device when doing the full image update because the port didn't seem to have the alias, so after ctrl+c the full image update process, the proxmark3 was still in the update mode (the red leds were on), and running the command again worked since it found the correct port for the proxmark3.

It looks like when you got the error about the bootrom not being found, you were running the command in the pm3 client, which doesn't sound correct.

I get the feeling that the pm3-flash-all command will work after the device is already running a version of the rrg/iceman fw. The repo is really active so I'll be pulling the latest changes often and will test out pm3-flash-all again.

Offline

Board footer

Powered by FluxBB