Proxmark developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2017-04-15 03:20:52

koulikov
Contributor
Registered: 2017-04-15
Posts: 11

[Solved] Trouble flashing IceMan's fork bootrom

Hello,

I have flash the proxmark3 with an old flasher.Exe because the last one doesn't work.

Iceman Bootrom version 05/04/2017/

---------
flasher.exe com4 -b bootrom.elf
Loading ELF file 'bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000c20->0x00000c20) [RWX] @0x298

Waiting for Proxmark to appear on USB..................... Found.
Entering bootloader...
(Press and release the button only to abort)
Waiting for Proxmark to reappear on USB.......... Found.

Flashing...
Writing segments for file: bootrom.elf
0x00100000..0x001001ff [0x200 / 1 blocks]. OK
0x00100200..0x00100e1f [0xc20 / 7 blocks]....... OK

Resetting hardware...
All done.

Have a nice day!
-------

Since this flash, the proxmark doesn't work anymore. Led A and C stay red and no more com4 so I guess there is something wrong in this boot code.
I must now find a solution with a JTAG...

Which old bootrom version really work ?

Thanks for your help.

Last edited by koulikov (2017-04-30 23:09:07)

Offline

#2 2017-04-15 17:55:29

iceman
Administrator
Registered: 2013-04-25
Posts: 3,747
Website

Re: [Solved] Trouble flashing IceMan's fork bootrom

Just take the PM3 master bootrom and flash,    you dont need jtag or anything.  If the device is not identified by OS,  just unplug, press button and keep it pressed,  plug in,  flash,  release button.


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2017-04-15 18:46:38

koulikov
Contributor
Registered: 2017-04-15
Posts: 11

Re: [Solved] Trouble flashing IceMan's fork bootrom

I have follow this procedure and this doesn't work.

               ====================================
                FLASHING bootrom.elf, please wait...
                ====================================

Loading ELF file '..\firmware_win\bootrom\bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b68->0x00000b68) [RWX] @0x298

Waiting for Proxmark to appear on com4........................................................................


How it's possible to flash the bootrom without a serial com ?! I don't understand how you do that.
Keeping the button press do nothing...

Offline

#4 2017-04-16 13:16:12

ntk
Contributor
Registered: 2015-05-24
Posts: 690

Re: [Solved] Trouble flashing IceMan's fork bootrom

@iceman, @koulikov

When windows says "USB device not recognised" then only JTAG can help, there is no COM communication, nothing


modhex(ichbifhkhghuhehghkiehbihhkidifighgebecedfchihthbhkhrduhehvht)

Offline

#5 2017-04-17 14:22:50

iceman
Administrator
Registered: 2013-04-25
Posts: 3,747
Website

Re: [Solved] Trouble flashing IceMan's fork bootrom

no.  Windows might have assigned a new com port.   Look at your connected devices and see which com port your PM3 is located.


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#6 2017-04-17 21:41:08

Danz
Contributor
From: Dubai
Registered: 2015-10-24
Posts: 71

Re: [Solved] Trouble flashing IceMan's fork bootrom

I am having the same issue , the only successful old bottom to revert to was pm2.5 asper GUI , after you recover , you can try to update with one official firmware but older date , perhaps newer built have issue with our proxmark3 version .
Let me know if you find good firmware for your proxmark3(electhousv2 I presume)


ModHex(hfdudthbfchtiehuduhehvht)

Offline

#7 2017-04-17 23:49:21

marshmellow
Moderator
From: US
Registered: 2013-06-10
Posts: 2,007

Re: [Solved] Trouble flashing IceMan's fork bootrom

Listen to iceman.  Not sure why but devices with his flashed firmware have a tendency to change com ports in the middle of a flash on Windows. 
You have to cancel the flash, disconnect, begin holding the button, connect, identify new com port, run flasher again to new com port (all while holding the button)

But the key is, your firmware build must be valid for your device, Iceman's fork has different hardware options.

Offline

#8 2017-04-17 23:56:08

Danz
Contributor
From: Dubai
Registered: 2015-10-24
Posts: 71

Re: [Solved] Trouble flashing IceMan's fork bootrom

I did again, it stays onCOM4 the whole process, holding the button with correct com will result "error in nack reply", without holding the button on correct com will result "sending bytes to proxmark failed".


ModHex(hfdudthbfchtiehuduhehvht)

Offline

#9 2017-04-17 23:57:16

marshmellow
Moderator
From: US
Registered: 2013-06-10
Posts: 2,007

Re: [Solved] Trouble flashing IceMan's fork bootrom

Then you built the wrong firmware options for your device.

Offline

#10 2017-04-18 00:20:24

Danz
Contributor
From: Dubai
Registered: 2015-10-24
Posts: 71

Re: [Solved] Trouble flashing IceMan's fork bootrom

I figure it out, The flasher.ext in the precompiled iceman (gator thread) causes the nack reply issue, I replace flasher.exe with the one from the official build and it flashed just fine and as you said com port changed from 4 to 5 (where windows see boot mode as new device and assign it to new port) .

but on the same build, all proxmark commands cause a crash!!

I will message gator to check flasher.exe on iceman build.


ModHex(hfdudthbfchtiehuduhehvht)

Offline

#11 2017-04-18 00:38:21

marshmellow
Moderator
From: US
Registered: 2013-06-10
Posts: 2,007

Re: [Solved] Trouble flashing IceMan's fork bootrom

Follow Iceman's instructions on his fork to build your own compile environment.  It is fairly easy.

Offline

#12 2017-04-28 00:30:13

koulikov
Contributor
Registered: 2017-04-15
Posts: 11

Re: [Solved] Trouble flashing IceMan's fork bootrom

Thanks for all the answers.
I have work on a way to flash a new bootrom with buspirate but the at91sam7s512-buspirate.cfg on this website seeems not ok:

openocd -f at91sam7s512-buspirate.cfg
Open On-Chip Debugger 0.10.0-dev-00463-g0c2de8b-dirty (2016-12-10-14:57)
Licensed under GNU GPL v2
For bug reports, read
        http://openocd.org/doc/doxygen/bugs.html
Warn : Adapter driver 'buspirate' did not declare which transports it allows; assuming legacy JTAG-only
Info : only one transport option; autoselect 'jtag'
adapter speed: 1000 kHz
srst_only srst_pulls_trst srst_gates_jtag srst_open_drain connect_deassert_srst
embedded:startup.tcl:21: Error: Unknown param: -variant, try one of: -type, -event, -work-area-virt, -work-area-phys, -work-area-size, -work-area-backup, -endian, -coreid, -chain-position, -dbgbase, -rtos, or -defer-examine
in procedure 'script'
at file "embedded:startup.tcl", line 60
in procedure 'target' called at file "at91sam7s512-buspirate.cfg", line 30
in procedure 'ocd_bouncer'
at file "embedded:startup.tcl", line 21

Any idea on this new problem ?

Offline

#13 2017-04-28 10:57:24

iceman
Administrator
Registered: 2013-04-25
Posts: 3,747
Website

Re: [Solved] Trouble flashing IceMan's fork bootrom

I suggest you @koulikov open a new thread about jtag/buspirate usages.   Try to keep threads clean and to the subject


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#14 2017-04-28 20:59:58

koulikov
Contributor
Registered: 2017-04-15
Posts: 11

Re: [Solved] Trouble flashing IceMan's fork bootrom

Danz wrote:

I am having the same issue , the only successful old bottom to revert to was pm2.5 asper GUI , after you recover , you can try to update with one official firmware but older date , perhaps newer built have issue with our proxmark3 version .
Let me know if you find good firmware for your proxmark3(electhousv2 I presume)

I have the ELECHOUSE Proxmark3 Easy V3.
With buspirate I successfully flash it with pm2.4 bootrom and fullimage...

So now if I understand, I must use the flasher.exe of pm2.4 but which firmware to use ?!

Offline

#15 2017-04-28 21:10:32

iceman
Administrator
Registered: 2013-04-25
Posts: 3,747
Website

Re: [Solved] Trouble flashing IceMan's fork bootrom

you should compile/flash the latest source code from GitHub.


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#16 2017-04-30 23:08:34

koulikov
Contributor
Registered: 2017-04-15
Posts: 11

Re: [Solved] Trouble flashing IceMan's fork bootrom

Ok thanks for the help, the flash finally work.

Proxmark3 RFID instrument
bootrom: iceman/master/v1.1.0-2031-g5198807 2017-04-29 15:54:52
os: iceman/master/v1.1.0-2031-g5198807 2017-04-29 15:55:01
LF FPGA image built for 2s30vq100 on 2015/03/06 at 07:38:04
HF FPGA image built for 2s30vq100 on 2015/11/ 2 at  9: 8: 8

I confirm that the com port change when I did the firmware update.

Offline

Board footer

Powered by FluxBB