Proxmark developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

You are not logged in.

#1 2017-06-08 14:47:37

brantz
Contributor
Registered: 2014-03-19
Posts: 17

PM3 turns into brick (Solved)

Issue is solved by revert to another build

===================================
Hi fellows,

what a sad news! I just had some progress on my project, and suddenly tonight, after I wrote a few keys into device memory, and loaded them for a test, my lovely pm3 went to brick, no matter how many time I restart it, or hold the button to power on, flasher cannot recognize it.

- the OS still recognize pm3 as a ubsmodem

➜  iceman git:(master) ls -al /dev/cu.usbmodem14221
crw-rw-rw-  1 root  wheel   19,  57  8 Jun 23:06 /dev/cu.usbmodem14221

- start proxmark3 with it, return invalid serial port

➜  iceman git:(master) ./client/proxmark3 /dev/cu.usbmodem14211
ERROR: invalid serial port

- try with flasher, device can't be found

➜  iceman git:(master) ./client/flasher /dev/cu.usbmodem14211 armsrc/obj/fullimage.elf
Loading ELF file 'armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x00031748->0x00031748) [R X] @0x94
1: V 0x00200000 P 0x00133748 (0x00001ac0->0x00001ac0) [RW ] @0x317dc
Note: Extending previous segment from 0x31748 to 0x33208 bytes

Waiting for Proxmark to appear on /dev/cu.usbmodem14211.......................................................................

My device doesn't have Jtag interface, instead, it has a 6pin connection, which I don't have to use it.

Does anyone had experince on de-bricking pm3 with 6pin new connection?

Thank you guys so much


======================
Additional info, flasher returns unknow Proxmark mode

➜  iceman git:(master) ./client/flasher /dev/cu.usbmodemfa131 armsrc/obj/fullimage.elf
Loading ELF file 'armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x00031388->0x00031388) [R X] @0x94
1: V 0x00200000 P 0x00133388 (0x00001af4->0x00001af4) [RW ] @0x3141c
Note: Extending previous segment from 0x31388 to 0x32e7c bytes

Waiting for Proxmark to appear on /dev/cu.usbmodemfa131.. Found.
Error: Unknown Proxmark mode

Last edited by brantz (2017-06-08 23:43:17)

Offline

#2 2017-06-08 15:15:14

iceman
Administrator
Registered: 2013-04-25
Posts: 3,653
Website

Re: PM3 turns into brick (Solved)

Sad to hear,

Not sure if this search will link correct but,  for OSX ppl,  flashing like those two threads in the search result should do the trick.
http://www.proxmark.org/forum/search.ph … =416104508

Keeping button pressed - http://www.proxmark.org/forum/viewtopic.php?id=3203

obs
Looking at your last error: Unknown proxmark mode  looks like you will need to flash bootrom first,  to make sure it is the same.
I never seen this error before. There is always a first time.

if you are switching back to PM3 master from iceman fork,  make sure you flash bootrom aswell.
keep track of your comport (cu.usbmodem####) after you updated the bootrom. It might change.


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2017-06-08 16:13:20

brantz
Contributor
Registered: 2014-03-19
Posts: 17

Re: PM3 turns into brick (Solved)

iceman wrote:

Sad to hear,

Not sure if this search will link correct but,  for OSX ppl,  flashing like those two threads in the search result should do the trick.
http://www.proxmark.org/forum/search.ph … =416104508

Keeping button pressed - http://www.proxmark.org/forum/viewtopic.php?id=3203

obs
Looking at your last error: Unknown proxmark mode  looks like you will need to flash bootrom first,  to make sure it is the same.
I never seen this error before. There is always a first time.

if you are switching back to PM3 master from iceman fork,  make sure you flash bootrom aswell.
keep track of your comport (cu.usbmodem####) after you updated the bootrom. It might change.

Hi Iceman,

about a half hour ago, I managed to flashing bootrom while the button is pressed, and then I had to keep pressing it after the fullimagin is flashed.

➜  iceman git:(master) ./client/flasher /dev/cu.usbmodemfa131 -b bootrom/obj/bootrom.elf
Loading ELF file 'bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000c18->0x00000c18) [R X] @0x298

Waiting for Proxmark to appear on /dev/cu.usbmodemfa131. Found.

Flashing...
Writing segments for file: bootrom/obj/bootrom.elf
 0x00100000..0x001001ff [0x200 / 1 blocks]. OK
 0x00100200..0x00100e17 [0xc18 / 7 blocks]....... OK

Resetting hardware...
All done.

Have a nice day!
➜  iceman git:(master) ./client/flasher /dev/cu.usbmodemfa131 armsrc/obj/fullimage.elf
Loading ELF file 'armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x000310e0->0x000310e0) [R X] @0x94
1: V 0x00200000 P 0x001330e0 (0x00001af8->0x00001af8) [RW ] @0x31174
Note: Extending previous segment from 0x310e0 to 0x32bd8 bytes

Waiting for Proxmark to appear on /dev/cu.usbmodemfa131. Found.

Flashing...
Writing segments for file: armsrc/obj/fullimage.elf
 0x00102000..0x00134bd7 [0x32bd8 / 406 blocks]...................................................................................................................................................................................................................................................................................................................................................................................................................... OK

Resetting hardware...
All done.

Have a nice day!

But I can get into pm3 only once, and it can't tune itself at all (I have integrated antennas, it's always connected)

pm3 --> hw tune

Measuring antenna characteristics, please wait...........
No response from Proxmark. Aborting...
pm3 --> exit

after I exist it, I can no longer get in again, unless I repeat flashing bootrom > flashing fullimage  again.

it becomes a dead circle.

Last edited by brantz (2017-06-08 16:19:59)

Offline

#4 2017-06-08 16:24:41

brantz
Contributor
Registered: 2014-03-19
Posts: 17

Re: PM3 turns into brick (Solved)

Hi Iceman, after I reverted to the build on 2017-06-06, the problem is solved.
Not sure what could make this error, as I know there are quite a few changed in recent days.

Offline

#5 2017-06-08 23:12:54

iceman
Administrator
Registered: 2013-04-25
Posts: 3,653
Website

Re: PM3 turns into brick (Solved)

not sure if you are using iceman fork or the pm3 master.  I suggest you have a go at the latest pm3 master.  You will like it.

At least your pm3 is not a brick anymore.

Would you mind edit your first post and add the prefix "[solved]" to your subject


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

Board footer

Powered by FluxBB