Proxmark developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2017-09-07 23:39:37

nastronaut
Contributor
Registered: 2017-09-06
Posts: 5

Stuck in weird state trying to flash iceman rom

Hi all,

Not sure what I did wrong here as I've flashed a couple firmware images succesfully, but now seem stuck.

I started off on the latest proxmark3 bootrom and the proxbrute fork firmware. I then decided to give iceman's fork a try, so downloaded the repo, compiled everything successfully and started to flash the bootrom first using the client in the iceman repo.

That seemed to go well. I have a Elechouse easy, so I held down the button while flashing, and the bootrom flashed successfully. Next I went to flash the firmware. That didn't go so well, as my proxmark was not detected when I held the button down and plugged it in. After trying unsucessfully a few times and it not showing up, I then decided to try flashing without holding the button down, and here's my result:

./client/flasher /dev/cu.usbmodem1421 armsrc/obj/fullimage.elf
Loading ELF file 'armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x000314d8->0x000314d8) [R X] @0x94
1: V 0x00200000 P 0x001334d8 (0x00001a0c->0x00001a0c) [RW ] @0x3156c
Note: Extending previous segment from 0x314d8 to 0x32ee4 bytes

Waiting for Proxmark to appear on /dev/cu.usbmodem1421................................ Found.
Entering bootloader...
(Press and release the button only to abort)
Waiting for Proxmark to reappear on /dev/cu.usbmodem1421..................................................................... Found.
Note: Your bootloader does not understand the new START_FLASH command
      It is recommended that you update your bootloader


Flashing...
Writing segments for file: armsrc/obj/fullimage.elf
 0x00102000..0x00134ee3 [0x32ee4 / 408 blocks]^C

The device did appear, but nothing actually got flashed, it just hung trying to write segments before I finally killed it.

My proxmark isn't bricked, but I'm not in a weird bootrom/firmware state, and can't seem to flash either as I keep having the same result - it hangs, and nothing gets written. Here's my hardware info as it sits now:

Prox/RFID mark3 RFID instrument
bootrom: iceman/master/v1.1.0-2249-g45d46ab0 2017-09-07 16:50:05
os: master/v3.0.1-75-g1dae981-dirty-suspect 2017-09-07 20:30:41
LF FPGA image built for 2s30vq100 on 2015/03/06 at 07:38:04
HF FPGA image built for 2s30vq100 on 2017/07/13 at 08:44:13

uC: AT91SAM7S256 Rev B
Embedded Processor: ARM7TDMI
Nonvolatile Program Memory Size: 256K bytes. Used: 196179 bytes (75). Free: 65965 bytes (25).
Second Nonvolatile Program Memory Size: None
Internal SRAM Size: 64K bytes
Architecture Identifier: AT91SAM7Sxx Series
Nonvolatile Program Memory Type: Embedded Flash Memory

Any suggestions as to how I could finish flashing the iceman port?

Offline

#2 2017-09-08 09:26:51

willem
Contributor
From: Netherlands
Registered: 2017-08-30
Posts: 3

Re: Stuck in weird state trying to flash iceman rom

You are doing this on a Mac? I tried the same and it also failed, I noticed the proxmark3 is not coming back on /dev/cu.usbmodem1421
but at /dev/cu.usbmodem8888 .... check your /dev directory ....

Offline

#3 2017-09-08 23:11:40

ntk
Contributor
Registered: 2015-05-24
Posts: 701

Re: Stuck in weird state trying to flash iceman rom

iceman has declared not to use the iceman's fork after the release of main repo 3.0.

Is there any reason you insist to use iceman's despite his warning.

Have you tried main repo? or latest on main repo?


modhex(ichbifhkhghuhehghkiehbihhkidifighgebecedfchihthbhkhrduhehvht)

Offline

#4 2017-09-10 17:05:58

nastronaut
Contributor
Registered: 2017-09-06
Posts: 5

Re: Stuck in weird state trying to flash iceman rom

Well shit, I did not see that warning to not use his fork from main repo 3.0. In fact, going back and checking the readme on his fork, I still don't see that warning. Could you point me to it?

I'll try willem's suggestion and check if it's responding on a different port

Offline

#5 2017-09-10 17:24:11

iceman
Administrator
Registered: 2013-04-25
Posts: 4,070
Website

Re: Stuck in weird state trying to flash iceman rom

...well.. the latest iceman source is on pair with PM3 official v3.0.1..  So that warning is not valid anymore.

I'll edit my old post..


modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#6 2017-09-12 22:18:10

nastronaut
Contributor
Registered: 2017-09-06
Posts: 5

Re: Stuck in weird state trying to flash iceman rom

Finally got around to trying out willelm's suggestion, my proxmark ended up on /dev/cu.usbmodem88888881 when I was holding the button to flash it. Everything is working great now, thanks!

Offline

Board footer

Powered by FluxBB