Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-03-05 13:33:40

slp
Contributor
Registered: 2018-12-07
Posts: 8

[solved] Hitag2 working firmware for sim?

Hi,

I have set up Hitag2 access control lab (few readers + cards) to play. My setup is in password mode, so I have sniffed the password using RFIDler, and having it was able to read the cards content (also RFIDler). After cloning the blocks to a blank card it turned out the data content is somehow encoded using card UID - that is read-only first block and of course different on the cloned card than original. (Has anybody heard of "magic UID" Hitag2 cards by the way?). And the reader discards such cloned card with the same data content but differend UID.

So I can't clone the data to a blank card, but would like to emulate the card content (including UID), e.g. using Proxmark (RFIDler does not have support for emulation yet). I noticed the code for emulation is there in Proxmark, but I am unable to make it work so far.
Actually it looks like none of the Hitag2 functionality works for me. Starting from lf search (does not recognize tag), through lf hitag reader (nothing visible in sniff-pwm of RFIDler, "lf hitag reader 26" cannot read the card UID) up to the lf hitag sim - still quiet.
I have tried several various proxmark devices (including RDV4), as well as varioius firmware forks (including official, RRG, ...) but no luck. My proxmark devices work correctly for other LF so I don't think it is antenna. I would rather suspect some internal modulation issue, or maybe my other software setup...

Could anyone point me to a working Hitag2 firmware to start, what else can I check or what do I miss?

Last edited by slp (2019-03-13 15:14:52)

Offline

#2 2019-03-06 23:30:34

slp
Contributor
Registered: 2018-12-07
Posts: 8

Re: [solved] Hitag2 working firmware for sim?

I managed to make it working using version 3.1.0 from official repo:
https://github.com/Proxmark/proxmark3/releases/tag/v3.1.0

"lf hitag reader 26" reads UID, "lf hitag reader 21 <pass>" reads the tag blocks content to a file, and "lf hitag sim <file>" simulates it - the reader recognizes correctly the Hitag2 simulated by Proxmark.

I wonder what happened in the meantime - current official and RRG repos do not work for me with Hitag2.

Offline

#3 2019-03-07 07:52:30

piwi
Contributor
Registered: 2013-06-04
Posts: 641

Re: [solved] Hitag2 working firmware for sim?

Thanks for the bug report. Do you mean that none of the hitag commands work anymore? If not, which of the commands don't and which do work with the current realease?

A better way to report an issue with the code is to follow the link "Github Issues" on the top right of this page.

Offline

#4 2019-03-07 09:34:47

slp
Contributor
Registered: 2018-12-07
Posts: 8

Re: [solved] Hitag2 working firmware for sim?

Good point, I just initially blamed my setup not the Proxmark code, that's why I asked here. I will try to pinpoint the exact commit and will file issue with the details on Github.

Offline

#5 2019-03-13 11:02:08

piwi
Contributor
Registered: 2013-06-04
Posts: 641

Re: [solved] Hitag2 working firmware for sim?

Fixed. Thanks for raising such a detailed issue description on github which allowed to identify the root cause pretty soon.

Offline

#6 2019-03-13 15:15:47

slp
Contributor
Registered: 2018-12-07
Posts: 8

Re: [solved] Hitag2 working firmware for sim?

Thanks for such quick resolution!

Offline

Board footer

Powered by FluxBB