Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-02-10 12:23:49

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

[solved] have trouble installing proxmark3

hello everyone,
I'm trying to install proxmark3, when such an error popped up, as posted below. could anybody tell me how to deal with it?
<pcsc.c:27:10: fatal error: winscard.h: No such file or directory
#include <winscard.h>
          ^~~~~~~~~~~~
compilation terminated.
Makefile:345: recipe for target 'obj/pcsc.o' failed
make: *** [obj/pcsc.o] Error 1
>
sorry I don't know how to attach a picture.
any help is appreciated, thanks!

Last edited by dongshan (2019-02-10 12:30:34)

Offline

#2 2019-02-10 20:52:30

piwi
Contributor
Registered: 2013-06-04
Posts: 620

Re: [solved] have trouble installing proxmark3

See http://www.proxmark.org/forum/viewtopic.php?id=6224:

Note for Linux-Users: you need to have the pcscd and libpcsclite-dev packages installed. E.g. on Debian based systems run 'apt install libpcsclite-dev pcscd'. Respective Wiki has been updated by Fl0-0.

Offline

#3 2019-02-12 13:30:17

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

Re: [solved] have trouble installing proxmark3

thanks! problem has been resolved

Offline

#4 2019-02-12 13:48:47

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

Re: [solved] have trouble installing proxmark3

no further errors or warnings encountered anymore during the build of proxmark3,
but after the build, it seemed that my proxmark3 doesn't work, as posted below
<
yindongshan@yindongshan-ThinkPad-X1-Carbon-2nd:~/proxmark3/client$ proxmark3
proxmark3: command not found
yindongshan@yindongshan-ThinkPad-X1-Carbon-2nd:~/proxmark3/client$ proxmark3.exe
proxmark3.exe: command not found
>
and proxmark3 project didn't produce the 3 images as said in the manual "COMPILING PROXMARK SOURCE AND FIRMWARE UPGRADING",
<
The bootrom image - “./bootrom/obj/bootrom.elf”.
The FPGA image - “./armsrc/obj/fpgaimage.elf”.
The OS image - “./armsrc/obj/osimage.elf”.
>
I checked respective folders and no image files were created there.
any further help is appreciated, thanks a lot!

Offline

#5 2019-02-13 07:14:31

piwi
Contributor
Registered: 2013-06-04
Posts: 620

Re: [solved] have trouble installing proxmark3

If the build process didn't create the .elf-files, it possibly didn't create the executable as well.

Please post any warnings or error messages during the build process.

Offline

#6 2019-02-13 12:06:41

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

Re: [solved] have trouble installing proxmark3

you are right, no executable was created in ./client folder either.
what confused me is that there wasn't any error or warning note shown on terminal window, even I double checked it.

Offline

#7 2019-02-14 01:50:26

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

Re: [solved] have trouble installing proxmark3

waiting on-line, any hint about how to deal with this situation is appreciated.

Offline

#8 2019-02-14 04:49:46

piwi
Contributor
Registered: 2013-06-04
Posts: 620

Re: [solved] have trouble installing proxmark3

Hard to analyse the issue without any information. You just said that the build process completed without any errors or warnings but didn't succeed ...

Please provide the output of the build process. If it doesn't fit on one or two screens, please don't paste here but share it on some cloud storage.

Offline

#9 2019-02-15 12:59:15

dongshan
Contributor
Registered: 2019-02-08
Posts: 12

Re: [solved] have trouble installing proxmark3

solved
I tried to rebuild proxmark3 by typing "make all && make clean" in ./proxmark3 folder instead of in ./proxmark3/client folder.
the three image files were created as well as executable file in ./proxmark3/client folder.
thank you for your kind help!

Offline

Board footer

Powered by FluxBB